Back to generic DFSee 'documentation' page ...

DFSee screenshots

This is a collection of screenshots from older DFSee versions that show many of the available features.
Click on any of the screenshot thumbnails for a real-life sized image

DFSee version 7.01, showing the main menu

large image

Startup screen, with mounted disks, partition-map and the standard table with partition details.

large image

File menu, open object to work with. Required for many commands to specify the object to be handled
Other related functions like logging, running scripts, rebooting and mounting/unmounting disks are also located here

large image

File-open dialog, selecting a DFSee script to run
The File-open is a generic dialog allowing selection of the drive (letter) to use and either specify or select a directory/filename from a list

large image

File-save-as dialog, with the create-directory option
The File-save-as is a generic dialog allowing selection of the drive (letter) to use and either specify or select a directory and filename, create a new directory

large image

The FILE MOUNT submenu allows you to ADD more partionable media to the list of 'disks' available to other DFSee commands
You can add virtual (in memory) disks, physical ones and RAW imagefiles

large image

Edit menu, modify object data, high or low level, like:
- Partition tables (PTEDIT) using a dialog
- LVM information for one partition in a dialog
- Sector data, in HEX or ASCII format
- DFSee settings

large image

The dialog used to update LVM information for a single partition/volume selected from the menu item
After updating, you can use the PgUp and PgDn keys to update the previous/next partitions

large image

The partition-table-editor (PTEDIT) for low-level updates of the partition tables.
Allthough there is some intelligence built-in, it is easy to make mistakes!
Use higher level functions like 'CREATE' when possible.

large image

Find any kind of data on the currently opened object using this dialog
It allows 1 or 2 search strings, in ASCII, HEX or UNICODE with many additional options to restrict or further specify the search algorithm

large image

An example of one of the many other color-schemes that are available through the edit settings and properties submenu
The scheme shown here is based on the 'Norton Commander' and provides good readability

large image

FDISK menu, activated when a partitionable object like a disk is opened
Has functions unique to partitioning and LVM and done at the disk rather than the filesystem level
Showing the Set partition -> Hidden

large image

FDISK menu, Create new partition with the submenu list of available freespace areas opened.
Any freespace area at least one cylinder in size and useable for a new primary or logical partition will be selectable

large image

The dialog used to create new partitions in a selected freespace area
The size, type and other relevant options for the new partition can be specified

large image

The FDISK LVM submenu groups most commands and functions that are used to manage the information for LVM
The Logical Volume Manager used with later OS2 and eComStation operating systems

large image

FDISK menu, fast search whole disk for partition information as well as superblocks for the selected filesystem (here JFS)

large image

FAT menu, activated when a FAT object is opened
Has all functions that are unique to FAT filesystems, or that need specific processing for FAT

large image

HPFS menu, activated when a HPFS object is opened
Has all functions that are unique to HPFS filesystems, or that need specific processing for HPFS

large image

HPFS menu, check filesystem item, showing the results of that check on the screen
A CHECK operation is available for most filesystems and will show allocation integrity as well as some other possible error conditions

large image

HPFS menu, recover deleted or normal files to another drive
A (wildcard) selection of files to be recovered is made in a dialog
The results of recovering a few files is shown on the screen under the menu

large image

JFS menu, activated when a JFS object is opened
Has all functions that are unique to JFS filesystems, or that need specific processing for JFS

large image

NTFS menu, activated when a NTFS object is opened
Has all functions that are unique to NTFS filesystems, or that need specific processing for NTFS

large image

Sector Lookup Table (SLT) creation and display for an NTFS filesystem.
This table is used for the CHECK and IDENTIFY functionality as well as direct problem analysis based on an SLT display

large image

The 'identify' menu item available with all filesystems that support the
Sector Lookup Table (SLT) allows you to determine what any specified sector (number) belongs to.
It will display file information when available

large image

NTFS menu, searching for deleted files that have 'syst' in their name
This function is available for several filesystem and can also be used for normal (not deleted) files

large image

Action menu, showing the DFSDISK action used to gather information to repair damaged partition tables

large image

Action menu, showing a partition IMAGING action to create an image 'from a partition'
You select WHERE to create an image from in this menu, all other required information is specified in a dedicated dialog

large image

A combined file and option dialog where the imagefile to be created
can be specified with a file-save-as kind of dialog as well as most of the
options available like compression, sizes and multiple file operation

large image

Action menu, showing a partition RESTORE or COMPARE 'to a partition'
You select WHERE to restore or compare an image from this menu, all other required information is specified in a dedicated dialog

large image

A combined file and option dialog where the imagefile to be restored
can be specified with a file-save-as kind of dialog as well as most of the
options available like sizes and RESTORE/COMPARE or VERIFY modus

large image

Action menu, showing a disk to disk CLONE action to copy the whole contents of one disk to another one
This is usefull when upgrading a disk to a larger one, or when trying to recover a disk with bad sectors

large image

The dialog where you can specify WHAT to clone to WHERE and many options related to the cloning process

large image

Action menu, showing several of the MOVE and COPY functions available for the currently selected partition
These functions will use all partitioning, LVM and CLONE commands needed to perform the required work

large image

This submenu groups all functions available to use the DFSee sector list
after it has been created by other commands like DELFIND, SCAN or filesystem directory displays
Note that you can export/import the list too

large image

Display menu, show various objects in detail like:
- Partition tables in several formats
- Sectors related to the current one
- Read-only and Read-Write speed

large image

This display submeny allows you to quickly display a sector related to the current on in various ways.
Note the shortcut keys that are available for each selection, they work outside of the menu too ...

large image

Display menu, showing usage of the SPEED selection
Note the results displayed on the screen, with the Read-only speed more than 4 times faster than Read-write

large image

Help menu, with an overview of available generic commands, mode-specific commands,
startup switches for the program and an introduction to the user-interface
You can also display the 'about' dialog from here

large image

DFSee about dialog, showing the version of DFSee itself, some of the contributing tools, copyright and registration information.
It also shows the type and version of the operating system being used.

large image

Example of a DFSee help-window, showing the usage for the output window used for all command output.
Usually the help will have up to three levels of information, so use another F1 keypress to see the next level ...

large image